Welcome, Guest. Please login or register.
Did you miss your activation email?
November 23, 2017, 01:32:31 AM

Login with username, password and session length

Get the latest 3rd party updates  HERE
13543 Posts in 4160 Topics by 5268 Members
Latest Member: Khmart
Search:     Advanced search
+  EFW Support
|-+  Support
| |-+  General Support
| | |-+  DHCP on ALL Green Interfaces
0 Members and 0 Guests are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: DHCP on ALL Green Interfaces  (Read 941 times)
kiko
Jr. Member
*
Offline Offline

Posts: 1


« on: March 09, 2017, 03:25:16 AM »

Just starting to test EFW Community 3.2.2 with all updates as of yesterday. 

Started with 2 interfaces...one green one red.  Everything worked as expected.

Since, I have added 4 additional interfaces.  I have added 1 to Orange and the other 3 to Green.  DHCP is enabled on both Green and Orange.

Green DHCP only will assign an address the original eth1.  When I try to obtain a lease from eth2-4 I get noting.

Orange DHCP works as expected with the single interface eht5.

I'd like to get DHCP working on ALL Green interfaces and not just eth1.  Any thoughts or suggestions are welcome.
Logged
svritc_81
Full Member
***
Offline Offline

Posts: 27


« Reply #1 on: May 08, 2017, 01:33:16 PM »

Hello Kiko,

Could you try adding adding below Line to dhcpd.conf file

option 1: DHCPDARGS="eth0 eth1";
option 2: INTERFACES="eth1 eth2";

To make permanent changes you have add to dhcpd.conf.templet file

bye the way i have not tested these settings but these config options are unix style for dhcp server to listen for specified interfaces.

Regard's

S. Venkata Ramana.
Logged
svritc_81
Full Member
***
Offline Offline

Posts: 27


« Reply #2 on: May 08, 2017, 02:39:27 PM »

Hi Again,

I tested in my test firewall efw3.22:
1. modify green interface of EFW that is br0 in config file
vim /var/efw/ethernet/br0
eth0
eth1

save and reboot your EFW.

note: when i add 3rd nic I lost communication to EFW and getting huge RTOs, where as with 2 NICs it was bit stable. (this might be limitation of efw322 i am not sure).

and DHCP leases are also working as expected, i guess br0 is bonding with eth0 and eth1 NICs

2. you could achive this via web gui: system> network configuration>  wizard.

good luck
Logged
Dark-Vex
Full Member
***
Offline Offline

Posts: 43


« Reply #3 on: May 08, 2017, 06:27:41 PM »

Hello Kiko,

Could you try adding adding below Line to dhcpd.conf file

option 1: DHCPDARGS="eth0 eth1";
option 2: INTERFACES="eth1 eth2";

To make permanent changes you have add to dhcpd.conf.templet file

bye the way i have not tested these settings but these config options are unix style for dhcp server to listen for specified interfaces.

Regard's

S. Venkata Ramana.

This configuration make no sense IMHO.. The GREEN it's a bridge so it's not necessary to add the interfaces by edit the dhcpd.conf.tmpl
Just check if the interfaces are added into the bridge with "brctl show"
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Page created in 0.066 seconds with 18 queries.
Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Design by 7dana.com