Welcome, Guest. Please login or register.
Did you miss your activation email?
Sunday 25 August 2019, 03:39:26 am

Login with username, password and session length

CLICK HERE for the The official Endian Roadmap and Issue tracker
13939 Posts in 4244 Topics by 5974 Members
Latest Member: maironmendes
Search:     Advanced search
+  EFW Support
|-+  Support
| |-+  Hardware Support
| | |-+  VMWare ESX 3.5 install hangs cannot mount cdrom?? [SOLVED]
0 Members and 0 Guests are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: VMWare ESX 3.5 install hangs cannot mount cdrom?? [SOLVED]  (Read 11585 times)
GuyH
Jr. Member
*
Offline Offline

Posts: 2


« on: Saturday 02 April 2011, 09:49:07 am »

Trying to install EFW2.4 on an ESX3.5 server

boots from cd image ok, then blue screen and no further

Alt-F2 shows that it is cycling with the install failing at /bin/mountsource.sh

looking at that it uses kudzu to detect the cdrom

running kudzu manually it doesn't find the drive!! (at least I have found the problem!!)

It does detect the IDE adapter as an
"Intel Corporation 82371AB/EB/MB PIIX4 IDE"
using the ata_piix driver

but there are no cdrom(s) visible

Any help? ideas?

(looking in mountsource, there seems to be an option to install from a network image - anyone know how to do that?)
Logged
GuyH
Jr. Member
*
Offline Offline

Posts: 2


« Reply #1 on: Saturday 02 April 2011, 11:13:36 pm »

Interesting solution - I'll copy it here in case anyone ever has the same problem

I found no way to get kudzu to detect the cdrom drive, tried lots of different configs in the VM BIOS primary IDE, secondary IDE and ... nothing

I did notice that in /bin/mountsource.sh it looked at HD devices.

I created a small harddrive in VMWare, connected it to a debian VM.
In there, I mounted the EFW.ISO image and the new drive and copied the contents of the CD onto the drive.

Then mounted the drive as a 2nd scsi drive onto the efw VM

booted and STILL the installer hung !!!!

Looking in mountsource.bin again it looks for the source and then, wherever it finds it it mounts it on /cdrom
so I Alt-F3 into the shell and mounted /dev/sdb1 by hand onto /cdrom

and YAY! it worked

It was a struggle but I now have an excellent efw firewall replacement for my Smoothwall and, so far very pleased
Logged
g.vecchi
Full Member
***
Offline Offline

Posts: 21


« Reply #2 on: Thursday 23 June 2011, 07:18:11 pm »

Thank you very much, really useful!!
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Page created in 0.034 seconds with 19 queries.
Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Design by 7dana.com