Welcome, Guest. Please login or register.
Did you miss your activation email?
Wednesday 19 June 2019, 04:07:47 pm

Login with username, password and session length

The Latest Endian Firewall is now available for download HERE
13923 Posts in 4237 Topics by 5946 Members
Latest Member: sreekanumuri
Search:     Advanced search
+  EFW Support
|-+  Support
| |-+  EFW SMTP, HTTP, SIP, FTP Proxy Support
| | |-+  http proxy server unable to forward at this time
0 Members and 0 Guests are viewing this topic. « previous next »
Pages: [1] 2  All Go Down Print
Author Topic: http proxy server unable to forward at this time  (Read 18132 times)
david_thistlethwaite
Full Member
***
Offline Offline

Posts: 14


« on: Friday 11 February 2011, 11:27:02 am »

I admin several endian 2.4 systems and today they all stopped forwarding http request claiming that authentication was required.
No authentication is used.
Since this has happend on several machines all within 4 hours of each other I can only infer a bug or some type of attack ?

Any insights ?

David
Logged
hitek0001
Jr. Member
*
Offline Offline

Posts: 2


« Reply #1 on: Friday 11 February 2011, 02:05:07 pm »

Malformed CLAMAV database is causing the issue:
Feb 10 20:01:37 efw-1279312999 clamd[3136]: Running as user clamav (UID 1000, GID 107)
Feb 10 20:01:37 efw-1279312999 clamd[3136]: Log file size limited to 2097152 bytes.
Feb 10 20:01:37 efw-1279312999 clamd[3136]: Reading databases from /usr/share/clamav
Feb 10 20:01:37 efw-1279312999 clamd[3136]: Not loading PUA signatures.
Feb 10 20:01:37 efw-1279312999 clamd[3136]: Malformed database

run freshclam from ssh
then restartclamav
Logged
hitek0001
Jr. Member
*
Offline Offline

Posts: 2


« Reply #2 on: Friday 11 February 2011, 02:28:50 pm »

if freshclam still errors this worked on 2.4.1 for me:
Incase you still get an error with freshclam about malformed database here is the fix I had to do on sunvalley:
Ssh in:
cd /usr/share/clamav/
rm -Rf clamav-*
rm main.cvd
rm daily.cvd
rm safebrowsing.cvd
curl -O db.local.clamav.net/bytecode.cvd  add http colon slash slash before db (can't post links)
freshclam
restartclamav
Logged
bernieL0max
Full Member
***
Offline Offline

Posts: 30


« Reply #3 on: Friday 11 February 2011, 04:03:30 pm »

ALL of my Endian Community Edition boxes also fell over today with the same problem.
Logged
bernieL0max
Full Member
***
Offline Offline

Posts: 30


« Reply #4 on: Friday 11 February 2011, 04:11:24 pm »

When I look in "Services", "Antivirus Engine", it says "None of the activated services are currently using Clamav antivirus. Therefore updates are disabled."

yet I am using a transparent proxy and my access policy includes "Activate antivurs scan".

My SMTP Proxy also has "Scan mail for virus" enabled.

So why does it think "none of the activated services are currently using clamav"?
Logged
bernieL0max
Full Member
***
Offline Offline

Posts: 30


« Reply #5 on: Friday 11 February 2011, 04:29:29 pm »

ignore that last reply, after following instructions posted by hitek0001 the service is running and the update section is displaying the correct information.  Thank you.
Logged
emilinz
Jr. Member
*
Offline Offline

Posts: 2


« Reply #6 on: Friday 11 February 2011, 08:55:29 pm »

thanks !!! Resolved!!!!
Logged
jimmyzshack
Full Member
***
Offline Offline

Posts: 17


« Reply #7 on: Saturday 12 February 2011, 01:11:08 am »

ok i was able to get all 4 endian http servers working with this info, BUT i have endian server that i use to scan email and we are not getting any emails here is the message we are getting:

delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while sending RCPT TO).

Anyone know what to do to fix this?
Logged
jimmyzshack
Full Member
***
Offline Offline

Posts: 17


« Reply #8 on: Tuesday 01 March 2011, 12:05:35 am »

anyone else getting these error's again today? i have 2 endian machines with this problem but not all of them at least not yet.

ERROR

--------------------------------------------------------------------------------


The requested URL could not be retrieved
While trying to retrieve the URL: http://www.google.com/



The following error was encountered:

Unable to forward this request at this time.

Sorry, you are not currently allowed to request:
http://www.google.com/
from this cache until you have authenticated yourself.

This request could not be forwarded to the origin server or to any
parent caches. The most likely cause for this error is that:
The cache administrator does not allow this cache to make direct connections to origin servers, and
All configured parent caches are currently unreachable.
Logged
jimmyzshack
Full Member
***
Offline Offline

Posts: 17


« Reply #9 on: Tuesday 01 March 2011, 12:23:54 am »

I was wrong it's all of our endian machine. Malformed database. none of the instructions above or fixing this error.
Antivirus2011-02-28 08:21:53
clamd (5816)  Log file size limited to 2097152 bytes. Antivirus2011-02-28 08:21:53
clamd (5816)  Reading databases from /usr/share/clamav Antivirus2011-02-28 08:21:53
clamd (5816)  Not loading PUA signatures. Antivirus2011-02-28 08:21:54
clamd (5816)  Malformed database SMTP Proxy2011-02-28 08:21:56
Logged
Galas
Full Member
***
Offline Offline

Posts: 14


« Reply #10 on: Tuesday 01 March 2011, 12:30:02 am »

Yup, happening again ...  Roll Eyes

Removing everything from the folder is not solving it
Logged
alex_t
Full Member
***
Offline Offline

Posts: 15


« Reply #11 on: Tuesday 01 March 2011, 12:37:39 am »

I have the same problem

sequence:
cd /usr/share/clamav/
rm -Rf clamav-*
rm main.cvd
rm daily.cvd
freshclam
restartclamav

doesn't help.
freshclam ok, restart ok, proxy doesn't work.
Logged
Galas
Full Member
***
Offline Offline

Posts: 14


« Reply #12 on: Tuesday 01 March 2011, 12:52:51 am »

Got it working, you must also restart havp

Code:
restarthavp.py
Logged
jimmyzshack
Full Member
***
Offline Offline

Posts: 17


« Reply #13 on: Tuesday 01 March 2011, 01:39:01 am »

Don't know if they have been updated or not but i reboot the vm's after updating main and daily and it didn't fix it. I did have older copies of main and daily and restarted the VM's and it worked on all of them.
Logged
alex_t
Full Member
***
Offline Offline

Posts: 15


« Reply #14 on: Tuesday 01 March 2011, 03:49:27 am »

Code:
cd /usr/share/clamav/
rm -Rf clamav-*
rm main.cvd
rm daily.cvd
freshclam
restartclamav
restarthavp.py
Works!!!
Thank you  Smiley
Logged
Pages: [1] 2  All Go Up Print 
« previous next »
Jump to:  

Page created in 0.103 seconds with 18 queries.
Powered by SMF 1.1 RC2 | SMF © 2001-2005, Lewis Media Design by 7dana.com